I upgraded one of my lab hosts to ESXi 4.1 yesterday and was plagued with this error:

System Error: vmodl.fault.hostcommunication

A lot of people are getting this error without a lot of direction. As it turns out, this is because I upgraded one of my hosts to 4.1 without upgrading vCenter to 4.1. Silly me! Who would have thought that vSphere vCenter couldn’t manage a vSphere host because it’s rev is 0.1 higher?